New Mac app on join.me

Good news! Our brand new Mac app is now available on join.me. It’s new, improved, faster, slicker – but still the same join.me you know and love. Start a join.me session on your Mac at join.me to check out the new app.

Using a PC? We haven’t forgotten about you – stay tuned for a new Windows app coming to our beta site soon.

    
Alix Hagan

Written by

Alix Hagan joined LogMeIn in 2012 and has held roles in product and in marketing. As Senior Product Marketing Manager, Alix leads all messaging, content, and campaigns for join.me, the world’s fastest-growing collaboration solution.

14 thoughts on “New Mac app on join.me

  1. This is BROKEN for Mac OS X 10.5.8 – There are still a lot of users out there using version 10.5.8 of Mac OS X

  2. Has this release technically abandoned older macs? My Join.me was the best! Up until this week- now it no longer runs… I have a mac which I guess does not run 64-bit code.. so sad.

  3. I’m not able to install this new app on my MacBook Pro. I’m running OS 10.6.8. When I try to install I get this error: “This version of join.me requires a Mac that is able to run 64-bit code.”

    • With the release of our new Mac app in June, we had to stop supporting any Mac running on OS version 10.5 or any Mac running a 32-bit machine for several reasons. Unfortunately, there isn’t a separate app for the machines and OS’s we don’t support anymore. We had to do this for several reasons, and I’m truly sorry for the inconvenience.

      Maggie

  4. I’ve got a Mac Mini running 10.6 that recently auto-updated to the new join.me app, and it no longer works. Apparently the new app is 64-bit only, and my older Mac Mini does not support it. Do you plan on releasing a 32-bit version, or can I use the prior version, and if yes, where can I get it? Thanks.

    • Hi Sam,

      With the release of our new Mac app in June, we had to stop supporting any Mac running on OS version 10.5 or any Mac running a 32-bit machine for several reasons. Unfortunately, there isn’t a separate app for the machines and OS’s we don’t support anymore. We had to do this for several reasons, and I’m truly sorry for the inconvenience.

      Maggie

  5. Wow– It’s too bad that you no longer support 10.5.8 — I hate the fact that teamviewer will be a part of my life. Please reconsider supporting 10.5.8 — I still have a machine running OS9 at my house. Its not like I asking for you to support that.

  6. I had an older version (apparently) that was working fine on 10.8. I inadvertatnly deleted it as it was in my “downloads” folder. Now I can’t get the download to work on 10.8. Funny that what I had before worked fine… now… nothing.

Comments are closed.